Page 14 of 36 FirstFirst ... 4121314151624 ... LastLast
Results 157 to 168 of 422
    1. Modification System for vBulletin 4.x Details »»

      Modification System for vBulletin 4.x

      Version: 4.5, by (Administrator/Coder) Snog is offline
      Developer Last Online: Apr 2014 Show Printable Version Email this Page
      vB Version: 4.1.x Rating:  (12 votes - 4.92 average) Installs: 55
      Released: 12-16-2011 Last Update: 01-11-2013 Downloads: 187
      Supported DB Changes Uses Plugins Auto-Templates
      Additional Files Translations

      This is an add-on that was designed with vBulletin 4.1.5. It may not work on earlier versions of vBulletin.

      This mod creates complete mod/add-on/template type forums and posts in vBulletin 4.x similar to that on vBulletin.org and is what you are viewing this mod with now.

      Support and development of this mod has been taken over by me with Coroner's permission.
      The original vB.org javascript included with this mod is used with permission from Paul M at vB.org.

      Features
      - Coders/Designers and have donations via PayPal
      - Mod of the Month System
      - Update via PM / Email (defaults to PM)
      - Tagged/Downloaded/Installed/Updated tags in forumdisplay
      - Much, much more!

      NOTE: For product version checking, there is a mod for this from BOP5...
      http://snogssite.com/showthread.php?...-System-Add-On

      WARNING: This new version is no longer compatible with any Coroner versions, or any versions of his that were manually modified by other people.

      NOTES: User update notifications default to notification by PM. In order to receive email updates, the user must change their settings for the mod. This is because spam rules strictly forbid opt-out type systems. Users must opt-in to receive email updates.

      KNOWN ISSUES: RTL languages do not display properly.

      This mod is known to be working on vBulletin versions: 4.1.5, 4.1.7 through 4.2.2


      * INSTALLATION *
      ---------------------
      1) Upload the contents of the 'upload' folder to your forum's root.
      (If your forum's location is http://www.example.com/forums/, the root is /forums/)
      1a) If you are running a custom style you may also have to upload the contents of the images folder to your style's folder.


      2) Import the product XML file (product-modsystem.xml) into the Product Manager in AdminCP.

      3) Go to ACP->Styles & Templates->Style Manager, for your Style select Stylevars and click Go. Change doc_minWidth to Units: px Size: 955. If it's more than that already, that's fine. But if it's less, change it.
      Some custom templates may need this to be set higher for the modification system to display properly.

      4) Go to ACP->Usergroups->Administrator Permissions and set who should have Admin Permissions for the Mod-System.

      5) Go to ACP->Usergroup Manager and give each usergroup that should have Access to the Mod System permission to do so.

      6) If you do not see the MOD-System settings in the ACP, hit refresh on your browser, then click on MOD-System and select Settings.
      6a) Select all of the forums that will be turned into MOD forums in the General Mod-Forums setting. (use ctrl-click or shift-click for multiple forums)
      6b) Identify which forums you selected above will be Coder, Style and Article forums in the next 3 settings after General Mod-Forums.
      6c) The rest of the options should be self-explanatory.


      7) Go to ACP->MOD-System->Update Counter and run each update routine that is on that screen.

      8) Add or change the Versions, Coder Levels and Designer Levels as you wish in ACP->MOD-System.

      9) Go back to ACP->MOD-System->Settings and enable the Mod System if you haven't already done so.



      * UPGRADE INSTRUCTIONS FOR VERSIONS 2.8 and HIGHER *
      ----------------------------------------------------------------------
      1) Upload the contents of the 'upload' folder to your forum's root.
      (If your forum's location is http://www.example.com/forums/, the root is /forums/)
      1a) If you are running a custom style you may also have to upload the contents of the images folder to your style's folder.


      2) Import the product XML file (product-modsystem.xml) into the Product Manager in AdminCP.
      OPTIONAL: Versions prior to 3.9 may have been logging all file downloads from your site.
      This does not cause a problem for the mod system, but will show odd file names in the download log.
      To remove these log entries you must be logged into the ACP.
      Upload the modsystem_cleantable.php file located in the 'clean download log table' folder included with this mod to your admincp folder
      Log in to the ACP
      Manually execute the file by entering the URL to the file ie: http://yoursite.com/youradmincp/modsystem_cleantable.php
      Once the log table is cleaned you can remove modsystem_cleantable.php from your system.
      This utility may not remove files posted in the same thread as a mod. Those can be manually cleaned using phpMyAdmin. Or they can
      be left on the system with no harm.




      * History (Changelog) *
      ---------------------------
      4.5 (January 11, 2013)
      - Fix - Thread display override when user has set it to anything but linear-oldest first.
      - Fix - Downloaded index creation in install file.

      4.4 (November 20, 2012)
      - Fix - Datastore not being rebuilt with new installs resulting in a foreach error.
      (NOTE: This does not fix existing installs, see this post for how to fix the foreach error: Foreach Error Fix)

      4.3 (September 12, 2012)
      - Fix - Profile template problem where long mod names caused display problems.

      4.2 (August 20, 2012)
      - Fix - Mod system causing double display of multi-select forum choice on settings pages of some other mods.

      4.1 (July 10, 2012)
      - Fix - Installs not displaying properly when vB date/time options set to 'detailed'.
      - Changed article forum add button from 'Add New Mod' to 'Add New Article'.
      - Changed article forum thread labels from 'Mod/Developer' to 'Article/Author'.
      - Removed installs sort option from article forum.
      - Changed style forum add button from 'Add New Mod' to 'Add New Style'.
      - Changed style forum thread labels from 'Mod/Developer' to 'Style/Designer'.
      - Added phrases for 'Rate this Article' and 'Rate this Style'.
      - Added options to change background and font colors of first posts.

      4.0 (April 20, 2012)
      - Fix - Article template not displaying properly.

      3.9 (January 27, 2012)
      - Fix - Mod system recording all downloads from all threads.

      3.8 (January 27, 2012)
      - Fix - Appened version in post not showing properly when full WYSIWYG, or standard text editor is used.
      - Fix - Database error when downloading files (had to do with addition of version to posts, etc.).

      3.7 (January 26, 2012)
      - Fix - Download link and Screenshots not showing after first page in vB 4.1.10
      - Fix - Word wrap in mod description.
      - Fix - Member Profile tab interfering with other added tabs.
      - Fix - MOTM Poll not displaying links to nominated mods.
      - Add - Installed version to member info in posts. (This will not display until a mod is updated and downloaded or the member clicks installed again.)
      - Add - Option to show currently installed version to member comments. (This will not display in posts until a mod is updated and downloaded or the member clicks installed again.)
      - Note - I can no longer consider this mod compatible with Coroner's earlier versions. Upgrade script has been removed for now.
      - Note - includes/class_profiletab_modsystem.php can be removed from your server. It is no longer needed.

      3.6 (January 6, 2012)
      - Fix - Coder selected currency not being passed to donation on mod display page.

      3.5 (January 5, 2012)
      - Fix - Non-English date display (server must be set up with proper language encoding).

      3.4 (January 5, 2012)
      - Fix - Non-Admin users couldn't to donate to coder.

      3.3 (January 4, 2012)
      - Fix - Database error with MOTM.
      - Fix - Missing MOTM Scheduled Task
      - Add - User notification information display when a mod is marked installed.

      3.2 (December 26, 2011)
      - Fix - Database error with ACP->Mod-System->Update Counter Create Settings and Adjust Threads.
      - Add - Proper table indexes
      - Removed License Database Table

      3.1 (December 22, 2011)
      - Fix - Certified seal was appearing in the wrong place in template.
      - Completely removed Licensing options
      - Removed what was the experimental Post Thanks support.
      - Minor template tweeks.

      3.0 (December 20, 2011)
      - Fix - File names no longer lost in download log when new file is uploaded for an exisiting mod.
      - Fix - vBSEO Likes no longer disappear forum wide when Mod System is enabled.
      - Change - The mod information display now uses the stylevars imodhilite_backgroundColor and popupmenu_color when hovering on selections.
      - Removed Post Thanks option from settings menu for now.
      - Inadvertantly re-instated the Certified Seal options.

      2.9 (December 19, 2011)
      - Put supported graphic in message area back in mod post template.
      - Moved hard coded phrases to vB phrase manager.
      - Add - Sort by rating in forumdisplay threadlist header.

      2.8 (December 13, 2011)
      - No longer need to make template changes to forumdisplay template.
      - No longer need to make template changes to usercp_shell template.
      - No longer need to make template changes to showthread template.
      - No longer need to make template changes to postbit template.
      - No longer need to make template changes to postbit_legacy template.
      - Fix - Donations can only be accepted by coders or designers.
      - Fix - Sort by mod/developer.
      - Fix - Display of Tagged/Installed/Downloaded in forumdisplay.
      - Fix - Display of Installed/Developer graphic in threads.
      - Add - Display of Installed/Developer text in postbit control area.
      - Add - Tag mod selection in mod information block.
      - Add - Download count in thread display.
      - Add - Install count in forum display.
      - Fix - Sort by install count on forum display.
      - Fix - Modifications Member Profile display.
      - Fix - Article Display link in Member Profile.
      - Fix - Moved all templates related to Modsystem to Modsystem template group.
      - Add - 'Updated' to forum display.
      - Fix - Jump to comments.
      - Remove redundant download log from database.
      - Remove unused templates.
      - Correct errors and warnings.
      - Major reduction of query count in showthread.
      - Set color of Downloaded/Installed/Tagged/Updated for forumdisplay in Mod-Settings.
      - Fix - WGO box for mod statistics
      - Add - Option to turn WGO box on or off.

      2.6 & 2.7 were used for development and never released.

      2.5 and earlier were released by Coroner.

      * Language Files *
      ---------------------
      Romanian - by Teascu Dorin

      Download Now


      Show Your Support

      • If you like this modification support the author by donating.
      • This modification may not be copied, reproduced or published elsewhere without author's permission.
  1. #158
    Junior Member SCHWT's Avatar
    RE: Version 3.9

    Ahhh,
    OK. That's was, because on the Upload the Flash-Uploader crashed.
    I've reloaded many times, because the Uploader was frozen.
    Good to know.

  2. #159
    Senior Member New Joe's Avatar
    RE: Version 3.9

    Just installed this, and so far it's working out of the box fine.
    Although the only setting I can't find is the 'Support the Developer' part, the PayPal setting when starting a Modification Thread

  3. #160
    Administrator/Coder Snog's Avatar
    Quote Originally Posted by New Joe View Post
    RE: Version 3.9

    Just installed this, and so far it's working out of the box fine.
    Although the only setting I can't find is the 'Support the Developer' part, the PayPal setting when starting a Modification Thread
    First make sure the usergroup has permission to have donate options. ACP->Usergroups->User Group Manager. Select the usergroup and scroll down to Modification System to change the setting.

    Once that's done, go into your profile page and you'll now find an 'Edit Donation Options' in the menu on the left, in the 'My Account' section.

  4. The Following User Says Thank You to Snog For This Useful Post:


  5. #161
    Senior Member New Joe's Avatar
    RE: Version 3.9

    Quote Originally Posted by Snog View Post
    First make sure the usergroup has permission to have donate options. ACP->Usergroups->User Group Manager. Select the usergroup and scroll down to Modification System to change the setting.

    Once that's done, go into your profile page and you'll now find an 'Edit Donation Options' in the menu on the left, in the 'My Account' section.
    That's the one thanks.

    I would say to you, Link your site here and this Mod in your Signature on vb.org mate

  6. The Following User Says Thank You to New Joe For This Useful Post:


  7. #162
    Junior Member
    Database error in vBulletin 4.1.11:

    Invalid SQL:
    SELECT
    COUNT(*) AS threads
    FROM 84modsys_settings AS mods
    LEFT JOIN 84modsys_user_notification AS usn ON (usn.mod_threadid=mods.threadid)
    LEFT JOIN 84thread AS thread ON (thread.threadid=mods.threadid)
    WHERE usn.mod_tagged
    AND usn.userid=1
    AND thread.forumid IN (0,5,6,8,9,11,Array,Array,Array,Array,Array);

    MySQL Error : Unknown column 'Array' in 'where clause'
    Error Number : 1054
    Request Date : Thursday, March 8th 2012 @ 10:21:45 PM
    Error Date : Thursday, March 8th 2012 @ 10:21:45 PM
    Script : http://xxx/modsystem_miscactions.php?do=showtagged
    Referrer : http://xxx/usercp.php
    IP Address : 123.28.86.142
    Username : xxx
    Classname : vB_Database
    MySQL Version : 5.1.56-community

    Stack Trace:

    #0 vB_Database->halt() called in [path]\includes\class_core.php on line 426
    #1 vB_Database->execute_query() called in [path]\includes\class_core.php on line 503
    #2 vB_Database->query_first() called in [path]\includes\class_core.php on line 534
    #3 vB_Database->query_first_slave() called in [path]\modsystem_miscactions.php on line 879
    Error, help mi !
    Usercp.php (!

  8. #163
    Administrator/Coder Snog's Avatar
    Check your settings in General Mod Forums and re-select the proper forums in there.

    It looks like you might have included forums that don't exist?

    ALSO: If you have version 3.9 installed, please mark it installed. Without doing that I'm running blind and don't know what version you have.
    Last edited by Snog; 03-08-2012 at 10:57 AM.

  9. The Following User Says Thank You to Snog For This Useful Post:


  10. #164
    Junior Member
    3.9 ~!
    And i install in host window !
    Thanks....! I install in host linux is normal

  11. #165
    Junior Member
    Click image for larger version. 

Name:	demo.png.jpg 
Views:	3 
Size:	10.3 KB 
ID:	196Click image for larger version. 

Name:	demo1.png.jpg 
Views:	5 
Size:	18.5 KB 
ID:	197
    Demo !
    Edit?
    Image:
    Only authorized members can view images.
    Image:
    Only authorized members can view images.

  12. #166
    Administrator/Coder Snog's Avatar
    Something very strange in that first picture.

    There shouldn't be two General Mod Forums selection sections.

    Try uninstalling and re-installing.

    Can you tell me what linux version that is and how it's being run?
    Last edited by Snog; 03-09-2012 at 01:12 PM.

  13. #167
    Senior Member
    I love this mod. I just can't figure it out! Lol, is there a walk through? I'm trying to get it so I can add files to the post, but can't figure out where to do this. I'm sorry if this is a boring question, but would love some guidance.

  14. #168
    Senior Member
    RE: Version 3.9

    Ok. I figured out almost everything. Great mod. I've installed it on two sites. On one site, everything works PERFECTLY. However, on the other the donation button doesn't work. I've tried reinstalling and re-reinstalling. Nothing seems to fix the issue. I hope someone here can shed some light on the situation.

    The problem is that when clicking the support the developer button, it basically just reloads the page. WHen i click it here, it gives a drop down with an amount... the same thing it does on my other site. On the site it's not working on, it doesn't matter if the theme is default or a custom one. It just doesn't provide the drop down, only reloads the page. Thanks!

  15. #169
    Administrator/Coder Snog's Avatar
    Quote Originally Posted by Clutch these View Post
    RE: Version 3.9

    Ok. I figured out almost everything. Great mod. I've installed it on two sites. On one site, everything works PERFECTLY. However, on the other the donation button doesn't work. I've tried reinstalling and re-reinstalling. Nothing seems to fix the issue. I hope someone here can shed some light on the situation.

    The problem is that when clicking the support the developer button, it basically just reloads the page. WHen i click it here, it gives a drop down with an amount... the same thing it does on my other site. On the site it's not working on, it doesn't matter if the theme is default or a custom one. It just doesn't provide the drop down, only reloads the page. Thanks!
    The dropdown is actually a vBulletin function, not one that I wrote (other than including it in the mod system).

    Check your CSS settings. If it's set to store CSS files in the file system, turn that off and see if it works then.

Moderation Tools (0)
Page 14 of 36 FirstFirst ... 4121314151624 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •