• If you have obtained any of my premium add-ons from another site, you DO NOT have a valid license for those add-ons and no support will be given to you.
    The only place that can sell licenses for my premium add-ons is this site.
Game Thread Starter for XenForo 2.x

Game Thread Starter for XenForo 2.x [Paid] 2.0.7

No permission to buy ($25.00)

Sp4x

New Member
Validated XF Owner
Applications Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#2
Hey Snog,

Thank you for your Addon :) - I get an Error if i try to install the Addon. XF 2.0 RC 2

Code:
You must validate your XenForo license to see code
 

Snog

Administrator
Validated XF Owner
#4
Thanks for letting me know. I was so focused on people that would upgrade that I failed to test a new install.

Download the add-on again and upload the files to your server. It should run without a problem now.
 

Sp4x

New Member
Validated XF Owner
Applications Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#5
Now Tested. Works like a charm :) Thanks
 

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#6
I had this running on a site that's been upgraded to Xenforo2 already but the version of this addon was only 1.0.3 so I can't use the upgrade version, more than happy to buy a new license though.

Before I do I wanted to check I wouldn't get any problems with the old 1.0.3 version still being installed or is it best to uninstall it first?
 

Snog

Administrator
Validated XF Owner
#7
You must validate your XenForo license to see quoted content
If you were running a version prior to 1.0.5, you will not be able to see any of the images in your original game threads and will have to start over again.

You will need to uninstall the old version prior to installing the new version. The upgrade is exactly the same as the full version, but it is just at a discounted price for previous owners.

BUT - See your PCs before you do anything.
 

Snog

Administrator
Validated XF Owner
#8
Upgrade requirements have been reduced from 1.0.5 to 1.0.3. But you will still need to be storing game images locally.
 

Delazar

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
#9
When the cronjob starts, I get the message:
  • ErrorException: [E_WARNING] Creating default object from empty value . src/addons/Snog/Games/Cron/Update.php:256
#0 src/addons/Snog/Games/Cron/Update.php(256): XF::handlePhpError(2, '[E_WARNING] Cre...', '/var/www/xf2tes...', 256, Array)
#1 [internal function]: Snog\Games\Cron\Update::Update(Object(XF\Entity\CronEntry))
#2 src/XF/Job/Cron.php(35): call_user_func(Array, Object(XF\Entity\CronEntry))
#3 src/XF/Job/Manager.php(241): XF\Job\Cron->run(8)
#4 src/XF/Job/Manager.php(187): XF\Job\Manager->runJobInternal(Array, 8)
#5 src/XF/Job/Manager.php(76): XF\Job\Manager->runJobEntry(Array, 8)
#6 job.php(15): XF\Job\Manager->runQueue(false, 8)
#7 {main}

array(4) {
["url"] => string(8) "/job.php"
["referrer"] => string(30) "https://xxx.xxx.com/"
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 

Snog

Administrator
Validated XF Owner
#10
You must validate your XenForo license to see quoted content
Thanks, for letting me know. Again, that comes from me only testing upgrades and not new installs.

I've uploaded a hot fix to the download server.

Download the add-on and just upload the files to your server. There's no need to do anything else.
 

Gman13

New Member
Validated XF Owner
XF2 OSB Owner
XF2 Games Owner
#11
Hi,

I don't see "Post new game" option. I see old "Post thread".

When I go to add new thread I see in thread title instruction to paste game URL. When I paste it, and create new thread no game data is fatched. Same URL works on your test forum.

In php info I see that cURL is enabled:

cURL support enabled
cURL Information 7.29.0

Also, I have tested cURL with some online php example and it worked.
 

Gman13

New Member
Validated XF Owner
XF2 OSB Owner
XF2 Games Owner
#13
You must validate your XenForo license to see quoted content
No, default xenforo 2 style without any modifications.

I see "Post new game" when I remove option Mixed content. But still after I paste game URL and create thread It doesn't fetch game information.
I tried to install addon again but still the same problem.
 

Snog

Administrator
Validated XF Owner
#14
You must validate your XenForo license to see quoted content
If you have any other add-ons installed, disable them and see if the add-on works.

Then re-enable the add-ons one at a time until the add-on stops working to identify if there is one interfering with the game system.
 

Snog

Administrator
Validated XF Owner
#17
You must validate your XenForo license to see quoted content
Have you edited any templates in the default style?

Are there any errors in the admin area?

Check in Admin->Appearance->Template modifications and make sure the one shown below for the TGDb games is shown like this:
threadview.png

The numbers on the end should be at least 1/0/0. If they are 0/#/# then you've edited the thread_view template or something else is changing it.
 

Gman13

New Member
Validated XF Owner
XF2 OSB Owner
XF2 Games Owner
#18
There are only TGDb Game Thread Starter modifications and all are 1 / 0 / 0
And there is no errors loged in admin area
 

Snog

Administrator
Validated XF Owner
#19
You must validate your XenForo license to see quoted content
Would it be possible for you to send me a temporary user name and password and give admin access to me so I can try to debug why it's not working for you? Send the login info by PC if that's possible.
 
Top Bottom