• If you have obtained any of my premium add-ons from another site, you DO NOT have a valid license for those add-ons and no support will be given to you.
    The only place that can sell licenses for my premium add-ons is this site.
Social Groups for XenForo 2.1+

Social Groups for XenForo 2.1+ [Paid] 2.1.9

No permission to buy ($49.00)

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
If you would answer my questions it would help a lot. Without answers it's difficult, if not impossible to establish what happened.

The update did nothing with the group Photo area.

Could you please right click on one of the missing photos and check the image properties to see if they actually exist on your server in the location shown when you right click on them? And what is the location?

Also, what version did you upgrade from when the images disappeared?

You must validate your XenForo license to see quoted content
This error is saying that the forum for the group your were trying to delete doesn't exist.

Did you manually delete the forum from the Admin->Forums->Nodes list before attempting to delete the group? (this was possible in older versions of the add-on so you could have done it a long time ago)
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Sorry, no it isn't. If the user is a member of any groups, they can search discussions.

However after reviewing this, if no groups have discussions I can see why you might want to disable it. In the next release I'll probably include a check if any groups the person belongs to has a discussion area and if none do, the discussion search will be removed from the advanced search.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
There are no plans to do anything with prefixes directly in the group system.

But once a group forum is created, the admin of the site can create prefixes for use in a group forum in the normal way if it's really needed.
 

Tealk

Member
Validated XF Owner
XF2 Groups Owner
You must validate your XenForo license to see quoted content
I meant prefixes for groups themselves. I use the groups for pen and paper games and wanted to use the prefixes for the systems.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Ah, no. Nothing like that is planned.

Best suggestion I can come up with is to use categories for that.
 

Tealk

Member
Validated XF Owner
XF2 Groups Owner
There are very much systems I think then it becomes even more confusing to look for.
Maybe you can put it on the todo list?
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
"Prefixes" aren't for use in forum creation, so I don't see me writing a complete system to account for prefixes in groups either. Especially since group forums are created based on the group name.
 

Snog

Administrator
Validated XF Owner
Group prefixes won't be added.

The only other suggestion would be to add the "system" to the group name.
 

Chernabog

New Member
Validated XF Owner
Applications Owner
Raffles Owner
XF2 Forms Owner
XF2 Raffles Owner
XF 2 PayPal Owner
I am about to jump on board the Snog Social Groups train... it is looking really good and I am starting to lose faith in my initial provider. @Snog is there a complete feature list anywhere and I do notice it has been recently updated (thank you so much for keeping it alive and active) -- but I am curious if this is going to continue to be a work in progress, based off your personal and end-user suggestions/ideas, or is development is slowing? It looks really good.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
The major features are all listed in the add-on description. Some might have been missed, but I don't see any missing.

All of my add-ons are open for suggestions, and I do maintain a "wish list" for each add-on. But just like it's up to the XF developers for XenForo itself, it is ultimately my decision if something gets added or changed in my add-ons. And at some point I'm sure each add-on will reach a point where I feel it is stable and has all of the features it should have. As an example, the XF1 version of my Raffles add-on is stable and hasn't had any additions in 3 years. It's still supported, but hasn't had anything added to it.
 

Chernabog

New Member
Validated XF Owner
Applications Owner
Raffles Owner
XF2 Forms Owner
XF2 Raffles Owner
XF 2 PayPal Owner
Fair enough. As you can imagine and likely know, there's always a bit of uncertainty when moving from something you know to try something else. I am going to poke around the demo version and feature check both sides. In the bigger picture, there is also the quality of code which you're consistently praised on. I will look around and may pop a few feature ideas by you for your consideration. I haven't had an add-on by you that I have not been pleased with.
 

Tealk

Member
Validated XF Owner
XF2 Groups Owner
Hello @Snog,

Since the last update I get the following error message:
Code:
You must validate your XenForo license to see code
 

Haydric

New Member
Validated XF Owner
XF2 Forms Owner
XF2 Groups Owner
Code:
You must validate your XenForo license to see code
Still getting this error after the update.
 

Snog

Administrator
Validated XF Owner
Did you upgrade the add-on in Admin->Add-ons?

Could you please double check that the src/addons/Snog/Groups/Setup.php file on your server has this code in it?

Code:
You must validate your XenForo license to see code
If not, then you most likely didn't upload all of the files to your server and you may need to manually create the column.

If it does, then please check the table using PHPMyAdmin and see if the column exits. If it does, then it's possible another add-on is improperly extending the user privacy entity.

If this is a fresh install (and you're testing the new install) and not an upgrade to an existing install, uninstall the add-on, download the add-on again and re-install it as a new install again.
 
Top Bottom