• If you have obtained any of my premium add-ons from another site, you DO NOT have a valid license for those add-ons and no support will be given to you.
    The only place that can sell licenses for my premium add-ons is this site.
TMDb Movie Thread Starter for XenForo 2.1+

TMDb Movie Thread Starter for XenForo 2.1+ [Paid] 2.1.0

No permission to buy ($30.00)

suineg

Member
Validated XF Owner
TMDb Threads Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
What would be the proper method to find where a movie is linked so that I can unlink it and then repost it? I have a thread that got screwed up somehow.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
I'm not really clear on what you're asking so these will be my best guess at what I think you're asking.

1) Try searching for the movie title.
2) Try posting the movie again and you should be taken to the existing movie.
3) If you have a "Trash" area, try looking in there and/or empty that area.
 

suineg

Member
Validated XF Owner
TMDb Threads Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
You must validate your XenForo license to see quoted content
Weirdly it is linked now ... I don't know what one of my moderators did.

That being the case I am just wondering if there is a location in the database that I can eliminate a single title for when these things are screwed up on my end.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
If you gave me a better description of what the exact problem was I would be better able to answer your question. Otherwise "screwed up" really doesn't tell me much and it's very difficult to provide a solution with that description. ;)

The way you're asking is like going to a car mechanic without your car and asking him what the rattling noise might be. He would have no clue.
 

suineg

Member
Validated XF Owner
TMDb Threads Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
You must validate your XenForo license to see quoted content
Yeah this is very true. Let me give it one last shot to try and explain it.

We have an old forum that has 1000 threads in the movie section and almost as many in the TV section.

Every so often when we get spare time we like to clean up the old threads and merge them all into one thread per movie or show. Sometimes a properly linked movie thread is merged into a thread with the same name or similar name but that isn't the linked one using the addon. When I go to the menu to add the movie (or tv show) it says that movie is already there. I don't get a cover or anything in the first post for the obvious reasons.

So the solution for me is to go and "unlink" a specific id from the database to allow me to start over with the new combined mega thread.

So this is the movie that was having an issue recently that I was talking about. https://www.themoviedb.org/movie/76341-mad-max-fury-road

The TMDB id is 76341 so if there was a way that I could go in and delete that from the database either from the system somehow or manually in mysql so that I can redo it that would be great. I am sure that I could poke around and do it but then break everything so I am asking since you know how you have it stored and linked to a thread id.

So right now TMDB 76341 for me is linked to thread id 1088. How could I "undo" that easily if I wanted to.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Setting the TV threads aside for now, let's talk about the movie threads.

The "proper" way to do what you're doing is to merge the "Unlinked" thread into the "Linked" thread. That way the original linked thread would retain it's information and no changes would be needed.

Merging threads the way I mention (unlinked into linked) assumes the "Unlinked" thread was started after the "Linked" thread so posts will still flow in a semi-reasonable manner.

But, there is also several problems with doing what you're doing...

The original first post in the thread contains a "decoded" version of the movie information that gets displayed in the event the add-on is disabled or uninstalled. So, that post no matter where it is in the thread after a merge will still show the poster, etc. in that post.

If you're going to merge a "Linked" thread into an "Unlinked" thread, you should move all but the first post in the "Linked" thread to the "Unlinked" thread. Then delete the "Linked" thread with that single post. That will delete the information from the database. Then add the movie information into the "Unlinked" thread using the "Add information" function.

All in all, if you REALLY want to remove the movie information from the database, it's in the xf_snog_movies_thread table. Delete the row for the "Linked" thread's thread_id in that table. That should do it, but I won't support that if something goes horribly wrong. ;)

TV Threads are a much more complicated system than the Movie threads. I do not suggest or support merging threads the way you are at all.

Overall, I don't suggest merging threads like you are at all. You've experienced just one of the problems that can crop up. The only way I would merge threads is as new threads are created, you can merge them into a pre-existing "Linked" movie thread. Or, if there is no "Linked" thread, ASAP move the new thread into the movie forum and link it so all future posts/threads can be immediately merged into the "Linked" thread.

If the "Unlinked" thread is "older" than the "Linked" thread then I strongly suggest leaving it alone, closing the thread and referring people to the newer "Linked" version for future posts.

I hope that's clearer than mud. ;)

Basically it boils down to "Don't let movies be posted anywhere except in a Movie forum" ;)
 

suineg

Member
Validated XF Owner
TMDb Threads Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
You must validate your XenForo license to see quoted content
Yeah this is what I am looking for.

On all of the rest of it being improper, I totally get it.

Movies are only allowed to be posted in the movie forums at least but I am still just cleaning up old old threads that I will probably just leave alone from here on out to not have to deal with it.
 

Snog

Administrator
Validated XF Owner
FYI, I MAY add the ability to allow more than one thread to be posted for a movie the way I did with TV Shows.

I'm going to wait a while before I do that to be sure no nightmares happen with the TV starter where I might have to remove that ability.
 

crkgb

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
Hello,

How do I center the movie trailer on the post page? What template needs to be edited?
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
That would be the snog_movies_movie template.

The trailer is wrapped with the default XenForo bbMediaWrapper and bbMediaWrapper-inner classes which you will need to change or customize to your liking.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Now that's odd. That was the first error taken care of in version 2.0.1.

If this is a new install, uninstall the add-on and remove any threads from the movie forum. Then, download the add-on again, upload the files to your server and re-install.

Just to be sure that something didn't get mixed up, I've re-uploaded the files to the download server. So, be sure to download the add-on again and upload the fresh files before re-installing.

If this is NOT a new install and you have too many threads in the forum to deal with, using PhpMyAdmin go to the xf_snog_movies_thread table, click on the 'Structure' tab and select 'Change' for the tmdb_tagline column. Make it look like this and save it..
tagline.png

You'll still need to delete the one bad thread you mentioned in your PC.
 

crkgb

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
I used the database option. Worked like a charm. Thank you very much for your outstanding support.
 

Snog

Administrator
Validated XF Owner
WARNING: This add-on needs to be updated for XenForo 2.1.0 due to changes in XenForo 2.1.0. It will not work with XenForo 2.1.0 at this time. It will work with XenForo 2.0.x.
 

TurkBinGazi

New Member
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
XenForo version: v2.1.0 Beta 5
Add-ons: TMDb Movie Thread Starter 2.0.8 - [TH] Nodes 1.0.4(The latest version dated October 19th 2018, 2:11 pm)
I'm encountering this problem when the [TH] Nodes add-on is installed
There is a space between structItem-cell structItem-cell--movie and structItem-cell structItem--main
1545017398486.png
 

Snog

Administrator
Validated XF Owner
TH Nodes has not been updated for XenForo 2.1 therefore there is no way for me to properly check that add-on with my add-on.

Also, please refrain from posting bugs in XenForo 2.1 versions until XenForo 2.1 has been released as a "Release Candidate". Beta versions of XenForo 2.1 are not stable enough to use to create permanent fixes for add-ons yet and should not be used on a live site. If I fix something while XenForo is in Beta stage today, it could be broken again tomorrow.

Also note that there are already a few fixes that have been made for XenForo 2.1 but will not be released until XenForo 2.1 is released as a "Release Candidate".
 
Top Bottom