TMDb TV Thread Starter for XenForo 2.1+

TMDb TV Thread Starter for XenForo 2.1+ [Paid] 2.1.1

No permission to buy ($30.00)

Snog

Administrator
Validated XF Owner
Thanks for the report. I believe it was there in Beta 4. I'll look into it as soon as possible.
 

Nerdface

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
Not as critical as Movies, but still feel that a thread filter for actor (cast) would be useful for TV shows also if you have time to add it.. :)
 

NICK97

New Member
Validated XF Owner
TV Threads Owner
XF2 OSB Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Style Stats
Bug report for version: 2.1.0

TV episode image is not display on my website and the image is not updating

BC4CEA76-591B-4E7E-A051-703962AA1BF6.png
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Not a bug

There is no image available for the episodes that you show in the screenshot...

3047

But you appear to be missing the data/tv/EpisodePosters/no-poster.png image which should be showing.

3048

3049

Be sure that file exists on your server. If it doesn't exist you can copy it from src/addons/Snog/TV/defaultdata/EpisodePosters to data/tv/EpisodePosters
 

DeXTeR

Member
Validated XF Owner
Applications Owner
TMDb Threads Owner
Statistics Owner
OSB Display Owner
PayPal Balance Owner
TV Threads Owner
TGDB Threads Owner
Music Threads Owner
XF2 Forms Owner
XF2 Movies Owner
XF2 TV Owner
I am upgrading from XF1 to XF 2

TMDb TV Thread Starter · 2.1.12 -> 2.1.0
Code:
You must validate your XenForo license to see code
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
This is going to be very difficult to debug because the conversion from XF1 to XF2 uses the information contained in the actual episode post in XF1 to convert to XF2.

If you have ANY TV episode posts in XF1 where the Air date is not in the format YYYY-MM-DD, you must set them back to that format. This may have happened when one or more TV posts have been edited at some point.

Probably the easiest way to locate all episode posts would be using PHPMyAdmin on your xf_post table and find message LIKE%...% [EPISODEDATE] and check each one for it's content. Each one should have this format:
[EPISODEDATE]YYYY-MM-DD[/EPISODEDATE]

In other words, each date must look like this:
[EPISODEDATE]2000-01-31[/EPISODEDATE] Without any extra added characters or other information.

If you have SSH access to your server, you can also selectively dump the posts using this command:
Code:
You must validate your XenForo license to see code
The resulting episode_dump.sql file will contain all posts for TV episodes and each line will contain the post info like this:
Code:
You must validate your XenForo license to see code
The first number in the values is the Post ID, the second number is the Thread ID. That should make it easier to locate what posts have bad info.

The part you're concerned about is this:
Code:
You must validate your XenForo license to see code
 

Snog

Administrator
Validated XF Owner
I'll change the conversion routine in the next release so only 10 characters are imported.

But, if the Air Date has been edited to something like 10 jul 2000, it will be converted to 10 jul 200 which would technically be incorret. But if it's been edited, there's nothing I can do about that because the date should always have been 2000-07-10.
 

DeXTeR

Member
Validated XF Owner
Applications Owner
TMDb Threads Owner
Statistics Owner
OSB Display Owner
PayPal Balance Owner
TV Threads Owner
TGDB Threads Owner
Music Threads Owner
XF2 Forms Owner
XF2 Movies Owner
XF2 TV Owner
ok i somehow made to work it. After successfull installation i am not getting any posters.


 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Right click on the missing image and get the path for the image. What is shown? And does the image exist on your server?

Something that could happen is if you're running a test upgrade on the same server as your live site, is the path to the images might be pointing to your live site where they don't exist, but exist on your test site.

OR when you copied the site to do the test upgrade you didn't copy the data/tvthreads folder so the images were never moved and renamed in the new folder (data/tv).
 

DeXTeR

Member
Validated XF Owner
Applications Owner
TMDb Threads Owner
Statistics Owner
OSB Display Owner
PayPal Balance Owner
TV Threads Owner
TGDB Threads Owner
Music Threads Owner
XF2 Forms Owner
XF2 Movies Owner
XF2 TV Owner
Yes its a test site, and the path for the image also shows to the test site. But the poster is not there.

I tried to post new topic, the images are getting stored. But the old topics are not getting the posters.

 

Snog

Administrator
Validated XF Owner
Did you copy the data/tvthreads folder into the test site before you upgraded? Or did you just copy the database to a fresh install without copying everything from your live site?

If you didn't copy the data/tvthreads folder, the images didn't exist to be converted to the XF 2 version in the data/tv folder.
 

DeXTeR

Member
Validated XF Owner
Applications Owner
TMDb Threads Owner
Statistics Owner
OSB Display Owner
PayPal Balance Owner
TV Threads Owner
TGDB Threads Owner
Music Threads Owner
XF2 Forms Owner
XF2 Movies Owner
XF2 TV Owner
on the live site they were being shown directly from tmdb site. I have checked the option to store posters locally and turned on cron entries. lets see if on after real conversion these will show up or not.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Hmm, yes that would do it. I could have sworn I put a notice/warning up about images having to be stored locally before upgrading. But I don't know what happened to that notice. I'll put that up again both here and at XF.
 

Snog

Administrator
Validated XF Owner
FYI, in the next release there will be an option to replace all images for TV threads. That option is running here as a test so images are being updated here. That should help should any images be missing after upgrading from XF1.
 
Top Bottom