• If you have obtained any of my premium add-ons from another site, you DO NOT have a valid license for those add-ons and no support will be given to you.
    The only place that can sell licenses for my premium add-ons is this site.
TMDb TV Thread Starter for XenForo 2.x

TMDb TV Thread Starter for XenForo 2.x [Paid] 2.0.11

No permission to buy ($30.00)

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#2
Just tried updating to this new version on a test site and get the following error

Code:
You must validate your XenForo license to see code
This appears after clicking on Upgrade from the list of available addons, this is upgrading from v2.1.11
 

Snog

Administrator
Validated XF Owner
#3
You must validate your XenForo license to see quoted content
Thanks, it was looking for a value from the movie thread starter by mistake.

Download the add-on again, and upload all of the files to your server. There shouldn't be a need to do anything else except running the upgrade again. But, worst case you may need to restore your database to the test site to a point prior to attempting to upgrade.
 

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#4
Uploading the new files and running the upgrade worked fine.
 

Neal

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
#5
I get the following error after viewing the TV forum:

Code:
You must validate your XenForo license to see code
 

Neal

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
#6
Just to add that this error only appears in the admin panel after each visit to the TV forum on my website. I suppose this should really go in the TV addon area, and I couldn't edit the above as it gave me a spam warning :)
 

Snog

Administrator
Validated XF Owner
#7
Thanks, that is fixed now.

Download the add-on, upload the files and go to Admin->Add-ons and select 'Rebuild' from the dropdown for the TV add-on.

I would also suggest doing the same for the movie add-on since I also made some changes to it for compatibility reasons.
 

DirtRider

Well-Known Member
Validated XF Owner
Applications Owner
Raffles Owner
TMDb Threads Owner
OSB Display Owner
PayPal Balance Owner
Custom Add-On Owner
Social Groups Owner
XF2 Groups Owner
XF2 Raffles Owner
XF2 OSB Owner
XF2 Movies Owner
XF2 TV Owner
XF 2 PayPal Owner
XF2 Games Owner
XF 2 Style Stats
XF 2 Music Owner
#8
I just downloaded it now and ran into this issue when doing the rebuild. This is on a new install.

Oops! We ran into some problems.
Line 45: Only one else tag is allowed per if tag.
 

Snog

Administrator
Validated XF Owner
#9
You must validate your XenForo license to see quoted content
The old version of the Movie thread starter clashes with the new version of the TV starter.
You must validate your XenForo license to see quoted content
Disable the Movie thread starter, then re-run the rebuild for the TV thread starter.

Then rebuild the Movie thread starter with the new version of that and re-enable it.
 

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#10
Switched on development mode and get a warning at the top of my TV shows page, this is on my test site

upload_2017-10-22_16-9-47.png
 

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#11
Error
Code:
You must validate your XenForo license to see code
Stack Trace
Code:
You must validate your XenForo license to see code
Request State
Code:
You must validate your XenForo license to see code
 

Snog

Administrator
Validated XF Owner
#12
You must validate your XenForo license to see quoted content
That was already solved. Read the posts above yours...

Download both the TV and Movie thread starters, upload the files and go to Admin->Add-ons and click 'Rebuild' in the dropdown for each add-on.

In some cases you may need to disable the Movie add-on for the TV add-on to complete it's rebuild.
 

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#13
I have a top level category that I want to show featured shows on the forum Index as below screenshot

category.PNG

In v1 of the addon I seem to remember a way of getting the Add TV Show link to show in the category header as below
add.PNG

Is that still possible? If it is I can't remember how I did it before.
 

Snog

Administrator
Validated XF Owner
#14
You must validate your XenForo license to see quoted content
In XF 2 the ability to add shows, seasons, etc. in a category is permissions based.

tvperms.png

And if you're putting shows in a top level category, you need to enable 'Create pages for categories' in XF itself.

tvnodes.png

Then click on the category in the forum list on the site. The 'Add TV show' button will be in the category.

tvincategory.png
 

Snog

Administrator
Validated XF Owner
#15
You also might want to download the add-on, upload the files and do a 'Rebuild' for the add-on to correct the display for main page categories...

They shouldn't look like what you showed, they should look like this:

tvproper.png
 

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
#16
The Create pages for categories option was the issue. Screenshot was from a test board, ran the rebuild and now sorted.
 

Snog

Administrator
Validated XF Owner
#17
The fix for XenForo Beta 8 is now on the download server.

Download the add-on, upload the files to your server and 'Rebuild' from the XenForo add-ons menu.

NOTE!!! This add-on will no longer work properly with XenForo Beta 7 or earlier.
 
Top Bottom