• If you have obtained any of my premium add-ons from another site, you DO NOT have a valid license for those add-ons and no support will be given to you.
    The only place that can sell licenses for my premium add-ons is this site.
TMDb TV Thread Starter for XenForo 2.x

TMDb TV Thread Starter for XenForo 2.x [Paid] 2.1.0

No permission to buy ($30.00)

Creaky

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
Works perfectly, thanks.
 

BigPete7978

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
Haven’t had issues until now. Was already having a forum for posting TV Shows, but wanted to switch it to the Category mode where it posts the different season. Now I am getting errors when trying to post an individual TV Show. I followed the same steps on my new site, but it works there, but not here.

60A26632-E311-41B1-AF7C-D0D137BE0413.jpeg
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
That error is not from this add-on. It is coming from whatever add-on added the 'cv6_icon' field to the forum table.

The author of that add-on did not supply a default value for that field.
 

BigPete7978

New Member
Validated XF Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
XF 2 Music Owner
You must validate your XenForo license to see quoted content
I went in and looked at it. It was an add-on I had installed since I first upgraded to xF2, an add-on I don’t even use. Appreciate the heads up.
 

dandanch

New Member
Validated XF Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
I'm about to upgrade my forum from version 1 to version 2, and I need to upgrade this add-on as well but I don't see any instructions. can you help me with instructions. Thanks
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
The only requirement is that you were running version 2.1.11 or later for the XF1 add-on version and that all of the cron tasks for that version have completed running before upgrading to XenForo 2. And since it appears you upgraded the XF 1 version to 2.1.12 in April, you're good to go there.

Other than that, after you've upgraded your site to XF2, upload the XF2 add-on files to your server and go to Admin->Add-ons and click the upgrade button for the add-on.
 

dandanch

New Member
Validated XF Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
You must validate your XenForo license to see quoted content
I'm trying to set it up on my test site, it seemed to upgrade partially because I can see the options in the options section but when I go inside I'm seeing this error, and the upgrade is just continuously loading without completing.

DEBUG: TvThreads_addgroups - Callback Snog_TvThreads_Option_Group::renderOption is invalid (error_invalid_class).
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Where did you upload the XF2 add-on files to? And how are you upgrading?

Callback Snog_TvThreads_Option_Group is a callback in the XF1 version, not the XF 2 version.

It sounds like you're trying to install the XF1 version in XF2 or vise versa.

In XF2, on the Admin->Add-ons page, you should see the TV Thread Starter as a Legacy Add-on...

legacy.png

And the Upgrade Option should be at the top of the page, you would click the Upgrade button...

upgrade.png
 

dandanch

New Member
Validated XF Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
Screenshot-2018-6-2 Add-ons - Admin control panel.png
after I upgrade the forum software to version 2 and then I upload your files to directory js, src and then addon.

then I go to the control, and it looks like this before I start the upgrade, and once I start the upgrade it just continuously upgrades and doesn't complete.
 

Snog

Administrator
Validated XF Owner
Ok, something is amiss there.

It shouldn't show as active like it is. It should show as being inactive (crossed out like mine shows).

Were all of the XF1 files available on your test upgrade system?

And if you're running the XF2 site in Debug mode, don't.
 

Snog

Administrator
Validated XF Owner
Let me run the upgrade on a test server to see if I can find anything.
 

Snog

Administrator
Validated XF Owner
OK, there was an error in the setup during an upgrade and I put a patch on the download server.

Download the add-on again, upload the files to your server and try to upgrade again.
 

dandanch

New Member
Validated XF Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
I uploaded the new files and now I'm getting this error,


You must validate your XenForo license to see quoted content
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
OK, I can fix that.

Oddly, the error I corrected was AFTER where that error takes place.

Am I able to see your XF1 installation if I go to your site? I want to see something. From the looks of it, it almost looks like you have some manually posted episodes (not using the TMDB link, but using the EPISODE BBCode) or some other problem I need to find.
 

dandanch

New Member
Validated XF Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
You must validate your XenForo license to see quoted content
It's a test testsite, but if you need to go to my live site that I haven't upgraded yet, I can do that.
 

Snog

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Yeah, it's the live site I want to see. Send me an admin login/password so I can have a look at what's going on there. Something is amiss. There shouldn't be any episode post that doesn't have a tvid
 

ArcadeSyndicate

New Member
Validated XF Owner
TMDb Threads Owner
TV Threads Owner
XF2 Movies Owner
XF2 TV Owner
XF2 Games Owner
hi snog, i guess i found a little bug, maybe you want to take a look at it...

pete.png

when you try to add a tv show info to an existing thread, no images are fetched. when you create a new thread, all works fine :oops:

tested this with the movie addon too, it works with existing threads as it should, no problems.

this is not really important, i just repost the thows, change the date and move existing replies to the new thread.


btw really great addons, bought the game thing recently too and music is on my list now. thx for the great work :)

best regards
 
Top Bottom