• Due to the tragedy everyone in the world is facing, all OzzModz and Snog's products are reduced by 20%. The price is updated and there is no need for a coupon. This will be until further notice.

What add-on is this?

duderuud

New Member
Validated XF Owner
XF2 Forms Owner
Registration Spaminator
I was just looking for this template/warning option.

Schermafbeelding 2020-03-18 om 19.08.11.png
 

duderuud

New Member
Validated XF Owner
XF2 Forms Owner
Registration Spaminator
Care to share on how to do that for all replies in a specific forum?
 

ozzy47

Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
Okay, this is what I have.

Template quick_reply_macros

Find:
HTML:
You must validate your XenForo license to see code
Replace:
HTML:
You must validate your XenForo license to see code
Change node_id == 167 to your node id
 

duderuud

New Member
Validated XF Owner
XF2 Forms Owner
Registration Spaminator
Thanks for your help.

Looks like the only thing added is an extra if statement ands the else $0.
Doesn't seem to work though, it just outputs the $0 for me:

Schermafbeelding 2020-04-13 om 15.53.38.png

Snippet from my edited macro:
Code:
You must validate your XenForo license to see code
 

duderuud

New Member
Validated XF Owner
XF2 Forms Owner
Registration Spaminator
Oh, you need to create an add-on for that I see. This is getting tricky for me...I'll let you know how it goes!
 

ozzy47

Administrator
Validated XF Owner
Well you really don't need to create an addon, just a template modification.
 

duderuud

New Member
Validated XF Owner
XF2 Forms Owner
Registration Spaminator
Again thanks! Getting closer:

Schermafbeelding 2020-04-13 om 17.48.28.png

That still doesn't work though. Do I need to edit something else?
 

duderuud

New Member
Validated XF Owner
XF2 Forms Owner
Registration Spaminator
Also tried changing the language and disabled all add-ons but that doesn't solve it also.
 

duderuud

New Member
Validated XF Owner
XF2 Forms Owner
Registration Spaminator
Could you post your entire quick_reply_macros please?

Because I think you made more edits. The phrase that should be custom is reply_placeholder (that is what is actually showing the text in the reply field) but your custom template now only seems to edit the phrase $placeholder.
 

Snog

Retired Administrator
Validated XF Owner
You must validate your XenForo license to see quoted content
I was the one that did the original template modification (Admin->Appearance->Template modifications) and I can verify that what ozzy47 Ozzy47 gave in this post is 100% correct.
And there are no other edits.

If you copied the "Find" info directly from what he posted, that could be the problem. XenForo converts tabs to spaces in posts. What he posted should be copied directly from the main template so the tabs are used. Otherwise, the "Find" will never match anything.

And you you are editing the template itself, you shouldn't be. That's what "Template modifications" are for. And what was given in the post won't help you at all because $0 does not exist in an actual template. $0 is a template modification variable for the original "Find" value.
 
Top Bottom