• If you have obtained any of my premium add-ons from another site, you DO NOT have a valid license for those add-ons and no support will be given to you.
    The only place that can sell licenses for my premium add-ons is this site.
OS/Browser Display for XenForo 2.x

OS/Browser Display for XenForo 2.x [Paid] 2.0.1

No permission to buy ($10.00)

Sylvain

New Member
Validated XF Owner
XF2 Forms Owner
XF2 OSB Owner
XF 2 Style Stats
#2
It seems that your add-on doesn't make the difference between Waterfox and Firefox
I use Waterfox and the add-on says that i am using Firefox
Can you fix it ?
 

Snog

Administrator
Validated XF Owner
#3
You must validate your XenForo license to see quoted content
Waterfox has been able to be distinguished in the past. Something might have changed.

waterfox.png

In order to see if it can be fixed, I'll need your user agent string. Go here:
https://www.whatsmyua.info/

And post it once you have it.

However, I have checked around and it appears that Waterfox might be reporting itself as Firefox now. I'll know for sure once I have your user agent string.
 

Sylvain

New Member
Validated XF Owner
XF2 Forms Owner
XF2 OSB Owner
XF 2 Style Stats
#4
Hi
My user agent is
Code:
You must validate your XenForo license to see code
 

Sylvain

New Member
Validated XF Owner
XF2 Forms Owner
XF2 OSB Owner
XF 2 Style Stats
#5
I think that it should be modify to
Code:
You must validate your XenForo license to see code
 

Snog

Administrator
Validated XF Owner
#6
Yep, as I suspected Waterfox is identifying itself as Firefox. You can see that on the whatsmyua.info page. Even they identify it as Firefox.

You must validate your XenForo license to see quoted content
Actually it should be...

Code:
You must validate your XenForo license to see code
 

Snog

Administrator
Validated XF Owner
#7
Either way, I can account for the bad user agent string that is identifying it as Firefox. I'll include that in the next release.
 
Top Bottom